Factom Network Issues
Incident Report for Factom
Resolved
This incident has been resolved.
Posted Nov 22, 2019 - 04:08 CST
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted Nov 22, 2019 - 02:59 CST
This incident affected: Factom Network.