Factom Network Issues
Incident Report for Factom
Resolved
This incident has been resolved.
Posted 12 months ago. Dec 20, 2017 - 06:37 CST
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 12 months ago. Dec 20, 2017 - 05:41 CST