Factom Network Issues
Incident Report for Factom
Resolved
system is back up.
Posted 21 days ago. Jun 04, 2018 - 16:38 CDT
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 21 days ago. Jun 04, 2018 - 15:10 CDT
This incident affected: Factom Network.