Factom Network Issues
Incident Report for Factom
Resolved
This incident has been resolved.
Posted 11 months ago. Jan 15, 2018 - 01:02 CST
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 11 months ago. Jan 14, 2018 - 23:04 CST