Factom Network Issues
Incident Report for Factom
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 05, 2018 - 16:00 CDT
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 3 months ago. Aug 05, 2018 - 14:26 CDT
This incident affected: Factom Network.