Factom Network Issues
Incident Report for Factom
Resolved
service has been restored
Posted 6 months ago. Jun 03, 2018 - 08:55 CDT
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 6 months ago. Jun 03, 2018 - 07:15 CDT
This incident affected: Factom Network.