Factom Network Issues
Incident Report for Factom
Resolved
The faulty server has been replaced with a backup. This should stop further stalls.
Posted 4 months ago. Jun 04, 2018 - 04:10 CDT
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 4 months ago. Jun 04, 2018 - 03:07 CDT
This incident affected: Factom Network.