Factom Network Issues
Incident Report for Factom
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 18, 2018 - 16:27 CDT
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 5 months ago. Jul 18, 2018 - 12:21 CDT
This incident affected: Factom Network.