Factom Network Issues
Incident Report for Factom
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 12, 2019 - 06:49 CDT
Update
We are continuing to investigate this issue.
Posted 2 months ago. Apr 12, 2019 - 06:49 CDT
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 2 months ago. Apr 12, 2019 - 02:55 CDT
This incident affected: Factom Network.