Factom Network Issues
Incident Report for Factom
Resolved
network is back up and running.
Posted 5 months ago. Jul 18, 2018 - 11:57 CDT
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 5 months ago. Jul 18, 2018 - 10:38 CDT
This incident affected: Factom Network.