Factom Network Issues
Incident Report for Factom
Resolved
This incident has been resolved.
Posted 19 days ago. Jul 31, 2018 - 19:57 CDT
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 19 days ago. Jul 31, 2018 - 18:41 CDT
This incident affected: Factom Network.