Factom Network Issues
Incident Report for Factom
Resolved
This incident has been resolved.
Posted 21 days ago. Oct 01, 2018 - 02:45 CDT
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 25 days ago. Sep 27, 2018 - 11:33 CDT
This incident affected: Factom Network.