Factom Network Issues
Incident Report for Factom
Resolved
The network is progressing again.
Posted 4 months ago. Jul 30, 2018 - 12:21 CDT
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted 4 months ago. Jul 30, 2018 - 09:29 CDT
This incident affected: Factom Network.