Durable Sandbox Network Maintenance
Incident Report for Factom
Resolved
Maintenance on the Durable Sandbox has been completed. Thank you for your patience.
Posted Sep 13, 2019 - 17:19 CDT
Identified
We are performing maintenance on the Factom network for Durable Sandbox. We expect this to be resolved shortly.
Posted Sep 13, 2019 - 14:06 CDT
This incident affected: Factom Harmony Connect.