Factom Network Issues
Incident Report for Factom
Resolved
This incident has been resolved.
Posted Jul 30, 2019 - 14:25 CDT
Investigating
The Factom Network is offline and we are investigating the issue.

We value your patience - please subscribe to our status page for real-time updates.
Posted Jul 30, 2019 - 09:33 CDT
This incident affected: Factom Network.